UI slowness and API Errors

Incident Report for SmartSuite

Resolved

This incident has been resolved.
Posted Dec 09, 2025 - 12:07 UTC

Monitoring

AWS CloudFront appears to be causing intermittent slowness for some customers.

We are monitoring and coordinating with AWS
Posted Dec 08, 2025 - 22:11 UTC
This incident affected: Application Accessibility and API.