Database latency
Incident Report for SmartSuite
Resolved
Database performance is back to nominal. We will continue to monitor the service to ensure there are no remaining issues.
Posted Mar 27, 2024 - 18:01 UTC
Monitoring
A fix has been implemented and we are monitoring the results.
Posted Mar 27, 2024 - 17:10 UTC
Investigating
We identified an issue where a maintenance process was increasing load on our primary database cluster. The process has been halted. We are now monitoring the situation.
Posted Mar 27, 2024 - 15:00 UTC
This incident affected: Application Accessibility, API, and Automations.